Friend can't click or continue when im hosting an online game


May 5, 2020
Reaction score
Hey Guys

Sorry if this is meant to be in 'weekly help' but I couldn't find it and I really need help with this one.

I've been hosting an online game with my mate every fm since 2011 and this year I hosted our usual one for 6 seasons with no issues until Monday morning.

When my mate joined the game it would come up with the main home screen but wont allow him to click anything or continue.

We started a brand new file and things were ok for about 1 game month and it happened again.

I sent him the save file to host and it worked fine!

I then figured out if I load the game and take control of both teams, wait for him to join, then relinquish control of his team and he takes control, it works again...until we continue once ?

I then tried it with another friend and again, he hosts and it's fine, I host and it does the same

I've deleted my cache files, verified files on steam, uninstalled and reinstalled the game, opened it from steam, opened it from a shortcut, deleted my logo and kit packs and updated my drivers....none of it has worked!

It appears to be my laptop with the issue as it works fine when my mates host

Can anyone help me out or had similar issues?
We seem to have found a workaround by forwarding ports..

we both opened fm21 ports for pc and steam.

Hey dude

My workaround was to use my phone as a hotspot because it was my internet for some reason, so it sounds like the port thing is correct.....mine just fixed itself one day and we're back on my internet now working fine!