Welcome to FM Base
Want access to our Standard Logo Megapack and P20 kit packs? You know what to do!
Register

Can i play the game with one of the oldest version?

wondervilla

Member
Aug 18, 2016
4
0
0
Hi everyone, this is my first post.
My FM updates itself automatically, and now i don't want to play it with 16.3.2 version. In any way, can i solve that problem?
 
Top