Welcome to FM Base
Want access to our Standard Logo Megapack and P20 kit packs? You know what to do!
Register

Custom Kit Not Appearing in Overview?

Aug 15, 2021
3
0
1
Had a custom kit created for a custom team that I do not control (Using the IGE to boost them to the prem so I can play them, it's a long story) however when I go to the teams Overview the kits do not appear and they instead appear like this...

1629049634492.png


Upon getting the kits I did the following...

For 2D kits --> Documents/Sports Interactive/Football Manager 2021/graphics/kits/
1629049948463.png


1629050019134.png


For 3D kits --> Documents/Sports Interactive/Football Manager 2021/graphics/3d kits/
1629049962393.png


1629050054008.png


Here is screenshot confirming Teams ID is correct:
1629050092438.png


Upon configuring this, in FM I went to FM > Preferences > Reset > Clear Cache, after this I clicked Reload Skin and now... Nothing... This is something I spotted a week or so ago so the game and PC and been restarted many times since then.

This is the first time I've ever installed a custom kit and I'm still fairly new to FM so there is every chance I'm missing something painstakingly obvious! Apologies if I have!

Does anyone have any idea why the kit isn't appearing correctly in the overview?

Note: I've not had a chance to play against this team yet so am not sure if their kit appears correctly in-game
 
Aug 15, 2021
3
0
1
UPDATE: Fixed it myself! Decided to put some time aside to get my troubleshooting hat on and look into it...

For anyone else who comes across a similar issue and struggles here are a few things to keep in mind...

FM > Preferences > "Use caching to decrease page loading times" <-- Make sure this is disabled
FM > Preferences > "Reload skin when confirming changes in Preferences" <-- Make sure this is enabled

With these settings clicking Reload Skin in Preferences should be enough however if, like me, you're using the IGE then there are a few more things to consider!

Go to the IGE menu and make sure that "Allow Licensed Kits" is enabled.
Go to the IGE Menu and click Edit Kit Details, make sure that the kit type (Home, Away, Third) that you're importing has an icon, shirt, shorts, socks and text, make sure that Alternative Kit Number is 0 on each part of the kit and make sure that Competition is not set to anything specific.

After doing these then Prefernces > Reload Skin should work.

The only other thing that I did (and I cannot comment on whether or not this made a difference) is at one point I saved my game, closed it, removed the 2d and 3d kits from the directory stated in the OP, I then re-loaded my game > Moved the kits back to the directory and Reloaded the skins.

This was an interesting way to spend a few hours on a Sunday so hopefully all of this makes your troubleshooting much shorter than mine was! I now feel like a self-professed expert on dealing with these issues so if anyone happens to have the same issues and the above doesn't help feel free to post here and I'll help you look into it if I've got the time! :)
 

Skojardu

Member
Feb 27, 2015
100
14
18
Göteborg
what is IGE menu.?
I have a simular problem, downloaded new kits and did what i always did befor in FM18-FM20, only the kit for home apears in match but not away kit,
The new away kit sholud be red not yellow. cant solwe this problem.
 
Aug 15, 2021
3
0
1
what is IGE menu.?
I have a simular problem, downloaded new kits and did what i always did befor in FM18-FM20, only the kit for home apears in match but not away kit,
The new away kit sholud be red not yellow. cant solwe this problem.
I know this is months old now but figured it's worth replying!

IGE is in-game editor :)
 
Top